2006 Census DataPacks

Importing CSV data and digital boundary files in MapInfo

The following step by step method is employed to how a user will obtain the correct data and
geographical labels integrated into the CSV data file and importing this file into MapInfo with
the corresponding digital boundaries and finalizing with a thematic map: See Help
document: GIS Users 'Walk Through'

Notes:

1. The CSV data and digital boundary file requires to be unzipped from the DataPack folder
structure prior to importing the .MID/.MIF boundary files into MaplInfo.

See Help document: How to unzip the CSV and digital boundary files

2. Prior to opening a CSV data table into Maplinfo the user may wish to integrate the
geography labels and cell descriptions to the CSV data file. These may be saved as .xls files
and opening in Maplinfo (version 7.0 and above). See Help document: Adding the
Geographic Labels and Cell Descriptors to CSV data files in Excel

Open the CSV data table into MapInfo

Once the data has had the geographic labels and cell descriptors added to the file in excel
and has been opened in MaplInfo and saved as a .tab file.

Prior to opening a CSV data table into Maplinfo, the user must go through a variety of steps
and save it to a Maplnfo .tab file before it can be used in the Maplinfo software. Please see
Help document: How to open the CSV data in Maplnfo.



Step 1

Open Maplnfo
Step 2

File > Open:

Locate the csv data files where they are stored on your directory, e.g.;
<drive>\BCP_ASGC_06_ R2\LGA\NSW\LGA_NSW_BOlnew.csv.

Select the data file for the geographic level. In this case select the LGA folder.
Select the State/Territory. In this case select the NSW folder.
Select the table. In this case, select the LGA_NSW_BO1new.csv file.

This opens the CSV data as a browser table. You may save it also as a .tab Maplnfo file, so
then you can work and edit the data file accordingly in MaplInfo, also. You must save the CSV
data as a Maplinfo .tab file if you want to join the data to digital boundaries to create a
thematic map.

B LGA_NSW_BO01 new Browser

Code Lalbel region_id |Total P_M | Total P_F Total P P |Aged_0_4_K|Aged_0_4_F|Aged_0_4 F|
| Loato0st | Atury (<) LGAI0050 22424 23,857 45,281 1522 1,491 M3
[ Leato 16 | Armidate Cumaresg (A) |LGA10110 11,193 12175 23,368 703 661 1,364
(| Laa1o 5t | Ashtield (4) LGAIMMS0 18,377 20,290 ¥8.687 1061 1,043 2200
| LAtz | Auburm (a) LGA10200 A3H34 HAM 64,958 2516 2,382 4593
O | Leatozst | Balin (5 LGA10250 18,462 19,999 B,461 1,16 aay 2M3
)| Leatomn | Bairanald (A LGA10300 1,263 1477 2,440 88 75 163
)| Lzatozs: | Bankstown (C) LGA103S0 54,095 5,394 170,489 &577 £,130 12,707
1| Loatoa7t | Batrurst Regional (&) | LGA10470 17,995 17,849 35,844 1,240 1115 2355
]| Lesat 050 | Baudkham Hils ¢4) LGA10500 78,777 80515 150,392 5344 5,229 10,573
| Lea10550 | Bega Valley (&) LGA10550 15,297 15,763 1 060 854 803 1,662
| Lzt 0800 | Batingan (&) LGAT0600 6,051 €365 12,417 303 327 630
| Loat0850 | Barrigan (&) LGAT0ESD 4,006 3,988 7,994 233 194 433
| Laat107st | Blacktown (£ LGAT0750 134 577 136,532 7,708 11,611 10,797 22408
| Lzt 080 | Bland (A) LGA10300 3048 3056 g102 198 by [ 414
| Lot (e3¢ | Biayrey () Le:a10850 3,300 3293 5,593 s | 25 455
| Lzt 03 | Bilue Mountsins (C) LA 0900 35452 3436 74,068 24dd 2264 4705
| Lo 0850 | Bogan (A) LGA1DS50 1,496 1,386 2,882 130 107 7
| Lezs1 1000 | Bombsta (&) LGA11000 1,258 1,285 2,543 A5 70 135] -
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Import the digital boundary file

The corresponding digital boundary file requires to be imported as .MID/.MIF into MapInfo and
then saved as Maplnfo .tab file prior to joining the datasets and creating a thematic map. See
Help document: How to open the digital boundaries in Maplinfo

Step 1

Select File > Open Table > locate and select the .MID/.MIF files saved as Maplnfo .tab files,
in this case <drive>\GEO_ASGC_06_R2\LGA\NSW\LGA_NSW_06.tab > Open.

To view all of the NSW select Map > View Entire Layer > All layers, OK - a map is
displayed showing the NSW Local Government Areas.

& LGA_NSW_06 Map FEIX

Joining the data file and map file using SQL Select

Once you have your data and digital boundary file open in Maplnfo, do the following.



1 LGA_NSW_BO1new Browser
Code Label region_id | Total F_M

Total_P_F

Tatal_P_P

Aged_t_4_h|Aged_o_*

LGATD0SE | Alury (C)
LGAT0N 10 | Armidade Dusmar
LA 50 | Ashdield (A)
LA | Auburn (A)
LiGAN025] | Badina (A)
LGANG0L | Badranald (4]
LGANDASE | Banksiown () "F
LGATO4TE | Bathurs Reglors
LGANDSOT | Badidwm Hills (A
LGATOSSE | Bega Valey (4]
LGAI0GOL | Belingen (A)
LGATDSSE | Berrigan (&)
LGATOTEL | Blackiown (2
LGAI0S0 | Blard (A)
LGANSSE | Blavyry [A)
LGANDEOL | Bhes Mourdains |
LGATDESE | Bogan (&)
LGAT100C | Bombala (4)

v s mmnll

| GA_NSW_D6 Map
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Step 1

Select Query > SQL Select - a similar dialogue box is displayed.

SOL Select

Select Columnsz:

Tables Ii

Colurnns E

Operators |i

Agaregates Ii

from T ables: LGA_MSW 06, LGA_MSWwW_BOTnew

where Condition:  |LGA_MNSW_06.LGA_CODE = LGA_NSW_BO1new Code

Group by Columns: I

Qrder by Columns: I

inta Table Mamed: ISeIectiDn

W Browse Fesults

F, | Cancel Clear Werify

Functions E

Save Template

Load Template

Help




Step 2
Select the Clear button to remove any previous dialogue.

From the 'Tables' drop down menu select both tables, i.e. LGA_NSW_06
andNSW_NSW_BO01lnew

Note: ensure you select the Map table first.

The following dialogue appears in the ‘where Condition' area, 'LGA _NSW_06.LGA_Code =
LGA_NSW_B01new.code'

Select Verify - the following dialogue box is displayed.

Mapinfo r$_<|

' E Swntax is correck,

Select OK.

Select OK - a Query 1 Browser is displayed, which has joined the data and map files
together.

B Queryl Browser

LGA_COD|LGA_TIAME AREA_SO_KW |STE_CODE  |STE_HAME Code | Labl vegion_inl | Total P M |Total PF | *|
I | LGATOOS | Akury (C) nix 1 | Mesw South Wales LGATD0SC | Aury (C) LGA10050 244 23,057
I [ L1 04 11 | Armidale Dumaresq (4) [ 1 | Mo Sowth Winies LGATIHAL | Armidale Dumanesq (4) | LGADT 1D 1,153 12,175
{2001 5 | Ashindd 4) ) 1| Mew Soumn Wses LOA10SE | Ashtasid (A3 O 50 19,377 20290
I (LGA10200 | Auburn (A) AT 1 | Mevwr South Wisles LGAT020C | Aubum (A) LGA10200 EEE] M
[ Lcan0i25 | Baina (4) [ 1 | M Sovtn sl LG 2L | Fralin (4) LGAI0Z50 18002 19,98
L1 0301 | Bbranadd (A) 71 50 1 | M Soutn sk LA 0I0C | Biakrarssid () LGAI0300 1263 1477
{21035 | Barksdown (5) 7654 1 | Mever Soutn Winies LOATD3SE | Bnikstow () LOAI0350 84095 B6,394
.li.ﬁ.Mﬂ:?l Batrarst Regional () IMGE 1 | Mevwr South Wisles LGA104TE | Batrirst Regional (A) | LGA104T0 17 555 17 Bag
[ a0 0501 | Bahiam Has (4) [ 1 | e Siontn whinies LA D50 | B il (4) L0500 T8I BE
I LGAn0550 | Begn Viley (4 BT 60 1 | Mewr South Wisles LGATDSSL | Biegh Viabey (8) LIBAI0550 15,297 15,763
{21050 | Belingen () 150204 1 | Merer Soutin Wisies LOA1DGOC | Belingsn (4) LEHA10500 £051 6,366
-|L¢A1M Berrigan (A) 2086 55 1 | Mew Soutn Wsles LGATD65L | Bierrigan (A) L0650 4 006 3808
I [L50.10751 | Btactiown (C) 006 1 | Mew Soutn Wisle LGATOTSL | Blackiown (C) LGA107T50 1M ETT 136,532
[ Lo 0500 | Bt (4) B.55051 1 [ Mo Sonh Winies LA BB0C | Bland (A) LA 10500 3046 3,056
| chanost | Sy (4) 152470 1| M Soun Wsies LGA10SSE | Bdrymey (4) L0850 3,300 3293
| it 050 | e Whountsins () 144 68 1| Mewr South Wisies LGA1OS0C | Bdue Mountaing () LiGAT0500 35432 38,13
[ L35 | Bogan (A 1l Bl 1 | Mo Sovth Winies LA HSE | Bogen (4) [ 1,456 1,306
ﬂlq.-l;:.-.nm Bl [A) 304484 1 | Mo Soutm s LA 100C | Bombads (A} L1000 1258 12%‘;]
¥

Note: Query browsers and maps are temporary tables. Therefore you should save the Queryl
Browser to make it a permanent table by selecting File > Save Copy As - a similar dialogue
box is displayed.



Save Copy As f'>__<|
Save T able:
Caricel
Help
Step 3

Select the Queryl Browser.
Select Save As - a similar dialogue box is displayed.
Step 4

Locate and select the location in which to save the Queryl table. In this case
C:\Data\Census 2006\GEO_ASGC_06_R2\LGA\Map_midmifANSW



Step 5
In the 'File name' area, type a name for the file. In this case LGA_NSW_06new.tab

In the 'Save as type' area leave as the default MapInfo (*.tab).

Select Save - the Queryl browser is saved.

Save Copy of Table As
Save in: IﬁNSW j = IfF EH-
ﬁ FRL LA _NSw _06. TAR

W

Tables Directony

Import Files
Dhirectar

File name: ILG.-'l'-._N 5w OBnew TAE j Save
j Cancel

Save az ype: IMapInfu:u [*tab]

Help

£+ Maplnfo Places
" Standard Places

Projection...

1l

Step 6

Select File > Close All.

\‘



Step 7

Select File > Open Table - a similar dialogue box is displayed.

Note: Alternatively depending on which version of Maplnfo you have, you may be able to
select File > Recent Files > LGA_NSW_06new.tab

Loak jre |&: NS

Tables Directary

Remate Tables

ﬁ R LGA_NSW_06. TAB

SW_OEnew, TAR

File name:

Files aof type:

" Maplnfo Places
" Standard Places

Brefered Wiew:

|LGA_NSW_DBnew TAE

| Maplnfo [ tab)

i

I.-’-'-.utu::matiu:

[T Create copy in Maplnfo format For read/write

Open

Cancel

Help
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Creating a Thematic Map
To create a Thematic Map of the Total Persons (C3) for the NSW Local Government Areas:
Step 1

Select Map > Create Thematic Map - the 1st step dialogue box is displayed.

Create Thematic Map - Step 1 of 3 E

Type: Template:  Sortby Mame ™ Sort by Time Fresview:
- T emplate M ame Titke
Ranges & tegion Ranges, Redrelow & claszes Subtitk
4 Point Flanges Default B nnntonnn
T m Reqgion Ranges, Magenta 4 classes B nontoonnn
| AT W Line Fanges Default O nnntonnn
. [0 nnntonnn
. W Feqion Ranges, RedGrey & clazzes 0
i nnnto nnn
Pie Charts W Fegion Ranges, Green 5 classes
E— m Region Fanges, Blue 4 clazses
i ﬂ Region Fanges, Redvelow 4 clazzes
Graduated W Region Ranges, Blue & classes
m Line Fangesz, Y arving *idth
% m Fedion Ranges, Grey 4 claszes
Dot Density W Region Ranges Default
W Region Ranges, Red 5 clazzes
W Region Ranges, Greenrellow 4 classes
individual | B Region Ranges, Blusloyan] 4 classes
ﬂ Foint Ranges, Waryving Size
W Region Fanges, Greenrellow b classes r
-
Mest » | Cancel Help

Step 2
Select the 'Type' as Ranges.
Select the 'Template Name'. In this case Region Ranges, RedYellow 5 classes.

Select Next - the 2nd step dialogue box is displayed.

Create Thematic Map - Step 2 of 3 f5__<|

Select a Table and a Field:

Table: |[NEf T

Field: |AREA_S0_KMS |

[ lgnore Zerces or Blanks

<Eack| ﬂe:-:t>| Ear‘u:el| Help |




Step 3

In the 'Table' area, from the drop down menu select the table. In this case
LGA_NSW_06new.

In the 'Field' area, from the drop down menu select the data item you wish to create a
thematic map of. In this case Total P_P (Total Persons).

Create Thematic Map - 5tep, 2 of 3 [5__<|

Select a Table and a Field:

Table: |LG&_MSW_0Bnew

Field: |AREA_SO_KMS
AREA_SO_KMS

NE3RAREE

[ lon =T copE
Tatal Pk

Place atick in the box 'Ignore Zeroes or Blanks.

Create Thematic Map - Step 2 of 3 r>__(|

Select a Table and a Figld:

Table: |LGa_NSw_DBnew -]
Field: | Total P_P =l

¥ lanore Zeroes or Blanks

<Eack| ﬂe:-:t>| Ear‘u:el| Help |

Select Next - the 3rd step dialogue box is displayed.
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‘Create Thematic Map - Step 3 of 3 @

Presview: Customize

L5 MNEW_O&new by Total PP
B 520000 272,000

B 31000w 62,000 Styles. . |
O 11000m 31,000

0 7000w 11,000 ﬂ
d

1000w 7,000

Swatch Size
* Fort Size
" Small

Murnber of Colurnns: |1 :I

Legend Label Order

" Large
T emplate
" Ascending ™+ Descending Sawe Az |
8 Lose ||| e |

< Back | k. | Cancel | Help |

Step 4

Customize the Ranges if you would like to produce a more visually effective Thematic Map.
To achieve this select the Ranges or Styles buttons and change the variables/colours within.

12



Step 5

Now amend the Title of the Legend.
Select the Legend button.

Amend the Fonts, if required.

Change the Legend title to something more suitable, i.e., in the 'Title' area type Total
Persons by LGA NSW and then Click on OK.

Create Thematic Map - 5tep 3 of 3 @

Presiew: Custamize

Total Persons by LEA MSW Ranges...
52,000 1 272,000
21,0001 652,000 Shyles...

7,000t 11,000
1,000 7,000

|
=
0 11,000t 31,000
O
O

Swatch Size
* Fant Size
" Small
" Large

Murmnber of Calurmns: |1 :I

Legend Label Order
Save bz,

(" Ascending ™ Descending
' 4 4

< Back | k. | Cancel | Help |

Template
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